This database is not supported on your current license when setting up Bitbucket DC with Aurora DB

Still need help?

The Atlassian Community is here for you.

Ask the community





Platform Notice: Data Center Only - This article only applies to Atlassian products on the data center platform.

Problem

Aurora DB is only supported by Bitbucket Data Center. When running through initial setup of a Datacenter instance, the setup wizard asks for the database before the licence. As Aurora DB requires a Datacenter licence, connecting to the Aurora DB fails with the message similar to:

"The target database is Amazon Aurora PostgreSQL 9.6.12. This database is not supported on your current license."

Workaround

In order to complete the setup wizard, we will need to use the internal database, then migrate after the setup wizard is done.

    1. Complete Setup with "Database: Internal" Selected.
    2. Log in to Bitbucket Server.
    3. In the administration area, click Database (under 'Settings').
    4. Click Migrate database and follow the instructions to migrate to Aurora DB.

Resolution

The issue is currently being tracked by  BSERV-12229 - Getting issue details... STATUS


Description
Product
Last modified on Jul 17, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.