Unable to access server on fresh install on Linux

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As of Bitbucket Server 5.x+, no logs are written to the BITBUCKET_INSTALL directory. The contents of catalina.out will be written to BITBUCKET_HOME/log/atlassian-bitbucket.log file.

Symptoms

After installing and starting Bitbucket Server for the first time, you're unable to access the server on http://<SERVER_NAME>:7990/

The catalina.out indicates that server started without error:

INFO: Starting Servlet Engine: Apache Tomcat/7.0.54
Aug 06, 2014 8:58:05 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-7990"]
Aug 06, 2014 8:58:05 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 13332 ms

Diagnosis

Check that port 7990 is allowing incoming connections:

sudo iptables -L

Cause

You're unable to access the server because the firewall is preventing connections on port 7990.

Resolution

  • Allow incoming connections on port 7990 by running the following command:

    sudo iptables -I INPUT -p tcp --dport 7990 -j ACCEPT

Last modified on May 2, 2017

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