Add-on installation fails with "An error occurred while provisioning the user for this app."

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Problem

You try to install an add on and you may hit into the specific error below, the steps you would follow would be similar to below : 

  • Navigate to manage add-ons page as a site admin

  • Try to install an add-on and the expectation is that the installation should be successful

But instead, the following appears as a pop up error message when you attempt above

"An error occurred while provisioning the user for this app. Please try installing it again, and if then problem persists then contact Atlassian support. "

Cause

Default application access requests would need to approved before attempting any add-on installation as this can be a pre-requisite to some of the add-ons

Resolution

You should ensure that there are no pending access requests. You can do this by following these steps: 

  1. Browse to access config page as site admin , i.e https://<instance>.atlassian.net/admin/accessconfig
  2. Review and approve any needed pending access , pay special attention to default groups access


Description
Add-on installation fails with "An error occurred while provisioning the user for this app."
Product
Jira, Jira Service Desk
Last modified on Jan 4, 2019

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