Can’t edit files in Confluence Server using Atlassian Companion app in Internet Explorer, Edge, Firefox, or Safari

Still need help?

The Atlassian Community is here for you.

Ask the community

This article applies to Confluence Server and Data Center 6.11 and later.

Problem

Confluence Server and Data Center users are unable to edit attached files using the Atlassian Companion app. When they click Edit with in the preview, or Edit on the attachments page, or macro, they are prompted to download the Companion app, even though the Companion app is running.

This problem is most likely to affect people who use:

  • Internet Explorer 11
  • Edge
  • Safari
  • Firefox, older than version 55
  • another desktop app running locally on port 31459.

Diagnosis

Confluence Server and Data Center versions 6.11.0 and above. These versions have the Atlassian Companion app enabled by default.

Instances with the Edit in Office dark feature  enabled don’t use the Companion app, so they are not affected.

Cause

Atlassian introduced the Companion App in Confluence 6.11.x to improve the experience of editing attachments in Confluence. When a user edits a file in Confluence, Javascript is executed in the browser to open a connection to a webserver embedded in the Companion App, which runs locally on the end users' computer. This was made as a WebSocket Secure (WSS) connection, using a private certificate issued to Atlassian.

Atlassian became aware of a vulnerability and immediately revoked this certificate, which meant that editing files stopped working in some browsers. See Confluence Security Advisory - 2019-12-18 (CVE-2019-15006) for details of this vulnerability, and the action you should take.  Note that the fix for the security issue does not resolve the problem of people not being able to edit files using Companion in some browsers. 

Workaround

Several workarounds are available for users who can't edit files due to this problem. 

Use an alternate browser

This problem does not affect people using Chrome or Firefox 56 or later.

Revert to Edit in Office

You can choose to enable the Edit in Office dark feature which will allow users to edit Microsoft Office documents. This workaround is only available in select Confluence versions, and there are limitations on the browser and operating system combinations that can be used to edit Microsoft Office files. See Edit in Office using the Office Connector: Configuration matrix for more information.

Disable Companion App integration in Confluence preview

You can also choose to temporarily disable the “Edit with” functionality in the Confluence preview. Users will not see the “Edit with” option. 

  1. Go to  > Manage apps.
  2. Choose System Apps from the drop-down menu then search for Confluence Previews.
  3. Click to expand the list of plugin modules.
  4. Disable the following plugin modules. Not all of these modules may be present in your version of the plugin.
    • Edit With plugin for the Media Viewer (companion-plugin)
    • Embedded 'Edit With' button (embedded-edit)

Future plans

We are currently working on a series of improvements to the Companion app for Confluence Server and Data Center to make it easier to install and use. These improvements include a redesigned Companion interface to better manage the files you are working on and reworking the Companion app to use a protocol handler, rather than the current WebSockets method to enable more customers to use this feature, and avoid problems like this one. We will be deploying these improvements in the coming months.


DescriptionCan’t edit files in using Atlassian Companion app in Internet Explorer, Edge, Firefox, or Safari due to a certificate problem.
ProductConfluence

Last modified on Dec 18, 2019

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.