Confluence Security Advisory - 2019-12-18

Confluence Security Overview and Advisories

On this page

Still need help?

The Atlassian Community is here for you.

Ask the community

Confluence Server and Data Center - Atlassian Companion Man-in-the-Middle - CVE-2019-15006

SummaryCVE-2019-15006 - Atlassian Companion Man-in-the-Middle
Advisory Release Date

 10:00 AM PST (Pacific Time, -7 hours)

  • Confluence Server
  • Confluence Data Center

Affected Confluence Server Versions

  • Starting with 6.11.0
  • 6.11.x
  • 6.12.x
  • 6.13.x before 6.13.10 (the fixed version for 6.13.x)
  • 6.14.x
  • 6.15.x before 6.15.10 (the fixed version for 6.15.x)
  • 7.0.x before 7.0.5 (the fixed version for 7.0.x)
  • 7.1.x before 7.1.2 (the fixed version for 7.1.x)
  • 7.2.x before 7.2.0 (the fixed version for 7.2.x)
Click here to expand...
  • 6.11.0
  • 6.11.1
  • 6.11.2
  • 6.12.0
  • 6.12.1
  • 6.12.2
  • 6.12.3
  • 6.12.4
  • 6.13.0
  • 6.13.1
  • 6.13.2
  • 6.13.3
  • 6.13.4
  • 6.13.5
  • 6.13.6
  • 6.13.7
  • 6.13.8
  • 6.13.9
  • 6.14.0
  • 6.14.1
  • 6.14.2
  • 6.14.3
  • 6.15.1
  • 6.15.2
  • 6.15.3
  • 6.15.4
  • 6.15.5
  • 6.15.6
  • 6.15.7
  • 6.15.8
  • 6.15.9
  • 7.0.1
  • 7.0.2
  • 7.0.3
  • 7.0.4
  • 7.1.0
  • 7.1.1

EAP and beta versions:

  • 7.2.0-rc2
  • 7.2.0-rc1
  • 7.2.0-beta1
  • 7.1.0-rc3
  • 7.1.0-rc2
  • 7.1.0-rc1
  • 7.1.0-beta1
  • 7.0.1-rc1
  • 7.0.1-beta2
  • 7.0.1-beta1
  • 6.15.0-rc1
  • 6.15.0-beta2
  • 6.15.0-beta1
  • 6.14.0-rc1
  • 6.14.0-beta1
  • 6.13.0-rc1
  • 6.13.0-beta1
  • 6.12.0-rc1
  • 6.12.0-beta1
  • 6.11.0-rc1
  • 6.11.0-beta1

Fixed Confluence Server Versions

  • 7.2.0
  • 7.1.2
  • 7.0.5
  • 6.15.10
  • 6.13.10
CVE ID(s)CVE-2019-15006

Summary of vulnerability

This advisory discloses a medium severity security vulnerability which was introduced in version 6.11.0 of Confluence Server and Confluence Data Center. Versions of Confluence Server and Confluence Data Center affected by this vulnerability:

  • from 6.11.0 before 6.13.10 (fixed in 6.13.10)
  • from 6.14.0 before 6.15.10 (fixed in 6.15.10)
  • from 7.0.1 before 7.0.5 (fixed in 7.0.5)
  • from 7.1.0 before 7.1.2 (fixed in 7.1.2)
  • from 7.2.0-beta1 before 7.2.0 (fixed in 7.2.0)

Atlassian Cloud instances have already been upgraded to a version of Confluence which does not have the issue described on this page.

Customers who have upgraded Confluence Server and Confluence Data Center to version 6.13.10, 6.15.10, 7.0.5, 7.1.2, 7.2.0 or higher are not affected.

Customers who are on any of the affected versions listed above, upgrade your Confluence Server and Confluence Data Center installations immediately to fix this vulnerability.

Atlassian Companion man-in-the-middle


Atlassian rates the severity level of this vulnerability as moderate, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

This is our assessment and you should evaluate its applicability to your own IT environment.


There was a man-in-the-middle (MITM) vulnerability present in the Confluence Previews plugin in Confluence Server and Confluence Data Center. This plugin was used to facilitate communication with the Atlassian Companion application. The Confluence Previews plugin in Confluence Server and Confluence Data Center communicated with the Companion application via the domain name, the DNS A record of which points at Additionally, a signed certificate for the domain was publicly distributed with the Companion application. An attacker in the position to control DNS resolution of their victim could carry out a man-in-the-middle (MITM) attack between Confluence Server (or Confluence Data Center) and the domain intended to be used with the Companion application. This certificate has been revoked, however, usage of the domain name was still present in Confluence Server and Confluence Data Center. An attacker could perform the described attack by denying their victim access to certificate revocation information, and carry out a man-in-the-middle (MITM) attack to observe files being edited using the Companion application and/or modify them, and access some limited user information.

Versions of Confluence Server and Confluence Data Center starting with 6.11.0 before 6.13.10 (the fixed version for 6.13.x, 6.12.x and 6.11.x), from 6.14.0 before 6.15.10 (the fixed version for 6.15.x), from 7.0.1 before 7.0.5 (the fixed version for 7.0.x), from 7.1.0 before 7.1.2 (the fixed version for 7.1.x), and from 7.2.0-beta1 before 7.2.0 (the fixed version for 7.2.x) are affected by this vulnerability. This issue can be tracked here:  CONFSERVER-59244 - Getting issue details... STATUS


We would like to acknowledge "SwiftOnSecurity" for reporting this vulnerability.


We have released the following versions of Confluence Server to address this issue:

We have released the following versions of Confluence Data Center to address this issue:

What you need to do

Atlassian recommends that you upgrade either to the latest Enterprise release version, which is 6.13.10, or to the latest version. For a full description of the latest version of Confluence Server and Confluence Data Center, see the Release Notes. You can download the latest Confluence Server and Data Center Enterprise Release from the download center.

Upgrade to a fixed version of Confluence Server and Confluence Data Center.

(1) If you have a current Enterprise release  version (an Enterprise release version released on 18 December 2017 or later), or an older version (released before 2 December 2018) upgrade to the latest Enterprise release version (6.13.10).

If you have version……then upgrade to this Enterprise release version:


6.13.10 (recommended)

(2) If you have a current feature version (a feature version released on 18 June 2019 or later), upgrade to the next bug-fix version of your current feature version.

If you have version……then upgrade to this bug fix version:

(3) If you have an older version (a feature version released before 18 June 2019) but cannot upgrade to an Enterprise Release version, upgrade to any of these versions.

If you have version……then upgrade to any of these versions:



If you are unable to upgrade Confluence Server or Data Center immediately, or are in the process of migrating to Confluence Cloud, then as a temporary workaround, you can update the Confluence Previews plugin manually, or disable Companion App integration in the Confluence Previews plugin. 

If you have Confluence 6.13 and later, manually upgrade the plugin

To upgrade the Confluence Previews plugin:

  1. Download the appropriate version of the Confluence Previews plugin for your version of Confluence from the table below.
  2. Go to  > Manage apps.
  3. Choose Upload and follow the prompts to manually install the plugin.

See Installing Marketplace apps: Installing by file upload for more information.

Confluence version

Confluence Previews plugin version with fix

Confluence 7.1.xconfluence-previews-9.1.5
Confluence 7.0.xconfluence-previews-9.0.4
Confluence 6.15.7 - 6.15.10confluence-previews-8.2.2
Confluence 6.15.0 - 6.15.6confluence-previews-8.1.5
Confluence 6.14.xconfluence-previews-8.0.7
Confluence 6.13.x (Enterprise release)confluence-previews-7.0.19

To confirm the plugin was updated correctly go to  > Manage apps and search for Confluence Previews plugin. Expand the listing, and check the version number matches the plugin version listed above for your version of Confluence. 

If you have Confluence 6.11 or 6.12, disable the Companion App integration

This will disable the "Edit with" functionality. To disable the Atlassian Companion App integration:

  1. Go to  > Manage apps.
  2. Choose System Apps from the drop-down menu then search for Confluence Previews.
  3. Click to expand the list of plugin modules.
  4. Disable the following plugin modules. Not all of these modules may be present in your version of the plugin.
    • Edit With plugin for the Media Viewer (companion-plugin)
    • Embedded 'Edit With' button (embedded-edit)
    • ADCClient AMD Wrapper (companion-client-wrapper)
    • Edit With button (companion-plugin-button)
    • Templates for Edit With feature (companion-plugin-templates)

To confirm the Companion App integration was disabled successfully, insert a file into a page. View the page and click the file thumbnail to view the file in the preview. The “Edit with” menu should not appear. 


If you did not receive an email for this advisory and you wish to receive such emails in the future go to and subscribe to Alerts emails.

If you have questions or concerns regarding this advisory, please raise a support request at


Security Bug fix Policy

As per our new policy critical security bug fixes will be back ported in accordance with  We will release new maintenance releases for the versions covered by the policy instead of binary patches.

Binary patches are no longer released. 

Severity Levels for security issuesAtlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at
End of Life Policy Our end of life policy varies for different products. Please refer to our EOL Policy for details. 

Last modified on Jan 8, 2020

Was this helpful?

Provide feedback about this article
Powered by Confluence and Scroll Viewport.