Confluence Security Advisory 2011-03-24

This cumulative advisory announces a number of security vulnerabilities that we have found in Confluence and fixed in recent versions of Confluence. We also provide upgraded plugins and patches that you will be able to apply to existing installations of Confluence to fix these vulnerabilities. However, we recommend that you upgrade your complete Confluence installation rather than upgrading only the affected plugins. Enterprise Hosted customers should request an upgrade by raising a support request at http://support.atlassian.com. JIRA Studio is not vulnerable to any of the issues described in this advisory.

Atlassian is committed to improving product security. The vulnerabilities listed in this advisory have been discovered by Atlassian, unless noted otherwise. The reporter may also have requested that we do not credit them.

In this advisory:

XSS Vulnerabilities

Severity

Atlassian rates the severity level of these vulnerabilities as high, according to the scale published in Severity Levels for Security Issues. The scale allows us to rank the severity as critical, high, moderate or low.

These vulnerabilities are not critical. This is an independent assessment and you should evaluate its applicability to your own IT environment.

Risk Assessment

We have identified and fixed a number of cross-site scripting (XSS) vulnerabilities which may affect Confluence instances, including publicly available instances (that is, Internet-facing servers). XSS vulnerabilities allow an attacker to embed their own JavaScript into a Confluence page. You can read more about XSS attacks at cgisecurity.com, The Web Application Security Consortium and other places on the web.

Vulnerability

The table below describes the Confluence versions and the specific functionality affected by each of the XSS vulnerabilities.

Confluence Feature

Affected Confluence Versions

Issue Tracking

Include Page macro

2.7 – 3.4.6

CONF-21604

Activity Stream gadget

3.1 – 3.4.6

CONF-21606

Action links of attachments lists

2.7 – 3.4.7

CONF-21766

Table of Contents macro

2.9 – 3.4.8

CONF-21819

Our thanks to Dave B, who reported the vulnerability in the action links of attachments lists. We fully support the reporting of vulnerabilities and we appreciate it when people work with us to identify and solve the problem.

Risk Mitigation

We recommend that you upgrade your Confluence installation to fix these vulnerabilities.

Alternatively, if you are not in a position to upgrade immediately and you judge it necessary, you can disable public signup to your wiki until you have applied the necessary patch or upgrade. For even tighter control, you could restrict access to trusted groups.

We also recommend that you read our guidelines on best practices for configuring Confluence security.

Fix

Confluence 3.4.9 or later fixes all of these issues. Some issues have been fixed in earlier versions as described in the table above. For a full description of this release, see the release notes. You can download the latest version of Confluence from the download centre. The most recent version at the time of this advisory is Confluence 3.5.

Patches

If for some reason you cannot upgrade to the latest version of Confluence, you can upgrade the relevant plugins (below) in your Confluence installation to fix the vulnerabilities described in this security advisory.

For details on upgrading Confluence's plugins using the plugin manager, see:

Patches are also attached to the relevant issues (listed in the table above) if you need to apply these fixes manually.

Please note that we have released a number of advisories about Confluence recently. We recommend that you review them and upgrade to the most recent release of the product or apply external security controls if you cannot. Most of the disclosed vulnerabilities are not critical and often present less risk when used in a corporate environment with no access from the Internet.

We usually provide patches only for vulnerabilities of critical severity, as an interim solution until you can upgrade. You should not expect that you can continue patching your system instead of upgrading. Our patches are often non-cumulative – we do not recommend that you apply multiple patches from different advisories on top of each other, but strongly recommend to upgrade to the most recent version regularly.

We recommend patching only when you can neither upgrade nor apply external security controls.

Include Page Macro

Supported Confluence Versions

Issue Tracking

File Name

Downloadable Patch

3.4.x

CONF-21604

confluence-advanced-macros-1.12.4.jar

Download

3.3.x

CONF-21604

confluence-advanced-macros-1.9.3.jar

Download

To apply this fix, use the plugin manager to upgrade the Advanced Macros plugin to a version greater than or equal to that specified in the file name above.

Activity Stream Gadget

Supported Confluence Versions

Issue Tracking

File Name

Downloadable Patch

3.3.x

CONF-21606

streams-confluence-plugin-3.3-CONF-21606.jar

Download

3.4.x

CONF-21606

streams-confluence-plugin-3.4.6.jar

Download

It's currently not possible to upgrade the Activity Streams Plugin automatically using the 3.4 plugin manager or the 3.3 plugin repository. Instead, you will need to manually install the plugin as follows:

  1. Download the JAR file for your version of Confluence (see above).
  2. Install the plugin manually using the "Upload Plugin" link on the "Install" tab of the plugin manager.
Action links of attachments lists

Supported Confluence Versions

Issue Tracking

File Name

Downloadable Patch

3.3.x, 3.4.x

CONF-21766

confluence-attachments-plugin-2.20.jar

Download

To apply this fix, use the plugin manager to upgrade the Confluence Attachments Plugin plugin to a version greater than or equal to that specified in the file name above.

Table of Contents macro

Supported Confluence Versions

Issue Tracking

File Name

Downloadable Patch

3.3.x, 3.4.x

CONF-21819

toc-plugin-2.4.12.jar

Download

To apply this fix, use the plugin manager to upgrade the Table of Contents Plugin plugin to a version greater than or equal to that specified in the file name above.

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport