Confluence Security Advisory - 2016-09-21

Confluence HipChat plugin - leaks secret key - HC-32766

Note: As of  September 2014 we are no longer issuing binary bug patches, instead we create new maintenance releases for the major versions we are backporting.

Date of Advisory:   10 AM PDT  (Pacific Time, -7 hours)

CVE ID: 

  • CVE-2016-6668 - The HipChat plugin for various products leaks the secret key it uses to communicate with a linked HipChat instance.

Product: Confluence and the Confluence HipChat plugin.

Affected Confluence HipChat plugin versions:

  • 6.26.0 <= version < 7.8.17

Affected Confluence product versions:

  • version >= 5.5.0 where the installed Confluence HipChat plugin version is >= 6.26.0 and < 7.8.17
  • 5.9.1 <= version < 5.9.14
  • 5.10.0 <= version < 5.10.4

Fixed Confluence product versions:

  • for 5.9.x, Confluence 5.9.14 has been released with a fix for this issue.
  • for 5.10.0, Confluence 5.10.4 has been released with a fix for this issue.

Summary of Vulnerability

This advisory discloses a critical severity security vulnerability which was introduced in version 5.9.1 of Confluence. Versions of Confluence starting with 5.9.1 before 5.9.14 (the fixed version for 5.9.x) and from 5.10.0 before 5.10.4 (the fixed version for 5.10.x) are affected by this vulnerability.

Atlassian Cloud instances have already been upgraded to a version of Confluence which does not have the issue described on this page.

Customers who have upgraded Confluence to version 5.9.14 or version 5.10.4 are not affected.

Customers who have downloaded and installed Confluence >= 5.5.0 and have a version of the Confluence HipChat plugin >= 6.26.0 and less than 7.8.17 installed.

Customers who have downloaded and installed Confluence >= 5.9.1 less than 5.9.14 (the fixed version for 5.9.x)

Customers who have downloaded and installed Confluence >= 5.10.0 less than 5.10.4 (the fixed version for 5.10.x)


Please upgrade the Confluence HipChat plugin in your Confluence installations immediately to fix this vulnerability.

The HipChat plugin for various products leaks the secret key it uses to communicate with a linked HipChat instance (CVE-2016-6668)

Severity

Atlassian rates the severity level of this vulnerability as critical, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

This is an independent assessment and you should evaluate its applicability to your own IT environment.

Description

The Confluence HipChat plugin exposed the secret key it used to communicate with a linked HipChat service in various pages. For this vulnerability to affect your Confluence instance you must have a HipChat integration established. To exploit this issue, attackers need to have access to a Confluence account that has either:

  • Create space permission (this is a default permission for all users)
  • Space admin permission for any space
  • Confluence Administrator or System Administrator permission

Using the secret key attackers can gain full control over a linked HipChat instance.

All versions of Confluence HipChat plugin from 6.26.0 before 7.8.17 are affected by this vulnerability. 

All versions of Confluence from 5.9.1 before 5.9.14 (the fixed version for 5.9.x) and from 5.10.0 before 5.10.4 (the fixed version for 5.10.x) are affected by this vulnerability. This issue can be tracked here:  CONF-43695 - CVE-2016-6668 - The HipChat plugin for various products leaks the secret key it uses to communicate with a linked HipChat instance. Resolved

Fix

We have taken the following steps to address these issues:

  1. Released Confluence version 5.9.14 that updates the bundled copy of the Confluence HipChat plugin to a fixed version.
  2. Released Confluence version 5.10.4 that updates the bundled copy of the Confluence HipChat plugin to a fixed version.
  3. Released Confluence HipChat plugin version 7.8.17 that contains a fix for this issue.

What You Need to Do

Upgrade (recommended)

The vulnerabilities and fix versions are described in the description section above. Atlassian recommends that you upgrade to the latest version.

Upgrade the Confluence HipChat plugin to version 7.8.17 or higher.

Upgrade the Confluence HipChat plugin to version 7.8.17 or higher. For instructions on how to update add-ons like the Confluence HipChat plugin see https://confluence.atlassian.com/display/UPM/Updating+add-ons. The HipChat for Confuence plugin marketplace entry can be found at https://marketplace.atlassian.com/plugins/com.atlassian.labs.hipchat.confluence-hipchat/server/overview.

If you cannot upgrade the Confluence HipChat plugin to version 7.8.17 or higher then upgrade Confluence to version 5.10.4 or higher.

If you are running Confluence 5.9.x and cannot upgrade to Confluence 5.10.4 then upgrade to version 5.9.14.


Next, follow these steps to rotate the secret key. 

You need admin permissions for both Confluence and HipChat to do this: 

  1. Log in to Confluence as a user with admin permissions and go to <your-confluence-site>/plugins/servlet/hipchat/configure
  2. Click Remove integration. This will sever the link and uninstall the add-on in HipChat.
  3. Once you land back on the HipChat Integration page, click Connect HipChat. This will re-establish the link between HipChat and Confluence with a new secret key.

For a full description of the latest version of Confluence, see the release notes. You can download the latest version of Confluence from the download centre.

Mitigation

If you are unable to upgrade your Confluence server or the Confluence HipChat plugin, then as a temporary workaround, you can disable or uninstall the Confluence HipChat plugin and the Atlassian HipChat Integration plugin in Confluence.

Support

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/.

References

Security Bug fix Policy

As per our new policy critical security bug fixes will be back ported to major software versions for up to 12 months for JIRA and Confluence.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

Binary patches will no longer be released. 

 Severity Levels for security issues Atlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at FIRST.org.
 End of Life Policy  Our end of life policy varies for different products. Please refer to our EOL Policy for details.  

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport