Confluence Security Advisory - 2017-04-19

Confluence Security Overview and Advisories

On this page

Still need help?

The Atlassian Community is here for you.

Ask the community

Confluence - Unauthenticated users can view the content of Confluence blogs and pages - CVE-2017-7415.

Note: As of  September 2014 we are no longer issuing binary bug patches, instead we create new maintenance releases for the major versions we are backporting.


CVE-2017-7415 - Unauthenticated users can view the content of Confluence blogs and pages

Advisory Release Date

10 AM PDT (Pacific Time, -7 hours)

Affected Confluence versions
  • 6.0.0 <= version < 6.0.7
Fixed Confluence versions

Versions of Confluence equal to and above 6.0.7 contain a fix for this issue.

  • 6.0.7
  • 6.1.0
  • 6.1.1
  • 6.1.2
CVE ID(s)CVE-2017-7415


Summary of Vulnerability

This advisory discloses a high severity security vulnerability which was introduced in version 6.0.0 of Confluence. Versions of Confluence starting with 6.0.0 before 6.0.7 (the fixed version for 6.0.x) are affected by this vulnerability. 


Atlassian Cloud instances have already been upgraded to a version of Confluence which does not have the issue described on this page.

Customers who have upgraded Confluence to version 6.0.7 or 6.1.0 or above are not affected.

Customers who have downloaded and installed Confluence >= 6.0.0 less than 6.0.7

Please upgrade your Confluence installations immediately to fix this vulnerability.


Unauthenticated users can view the content of Confluence blogs and pages (CVE-2017-7415)


Atlassian rates the severity level of this vulnerability as high, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

This is an independent assessment and you should evaluate its applicability to your own IT environment.



The Confluence drafts diff rest resource made the current content of all blogs and pages in Confluence available without authentication by providing a page id or draft id. Attackers who can access the Confluence web interface of a vulnerable version can use this vulnerability to obtain the content of all blogs and pages inside Confluence provided that they first enumerate page or draft ids.

All versions of Confluence starting with 6.0.0 before version 6.0.7 are affected by this vulnerability. This issue can be tracked here:  CONFSERVER-52222 - Getting issue details... STATUS


We would like to credit Yuvanesh for reporting this issue to us.



We have taken the following steps to address this issue:

  1. Released Confluence version 6.0.7 that contains a fix for this issue.
  2. Released Confluence version 6.1.0 that contains a fix for this issue.

What You Need to Do

Upgrade Confluence to version 6.1.0 or above (recommended)

Atlassian recommends that you upgrade to the latest version. For a full description of the latest version of Confluence, see the release notes You can download the latest version of Confluence from the download centre.

Upgrade Confluence to version 6.0.7

If you are running Confluence 6.0.x and cannot upgrade to the latest version then upgrade to version 6.0.7.

You can download this version of Confluence from our download archives.



If you are unable to upgrade right now, this issue can be mitigated in vulnerable versions of Confluence by disabling Collaborative editing as per the following instructions.

  1. Go to   > General Configuration > Collaborative editing.
  2. Change the collaborative editing mode to Off.

    Be aware that shared drafts will be lost when you switch to this mode, so make sure your users have published any work they want to keep before you make the change.

  3. Refresh the page and check that the Collaborative editing mode has changed to "OFF".



If you did not receive an email for this advisory and you wish to receive such emails in the future go to and subscribe to Alerts emails.

If you have questions or concerns regarding this advisory, please raise a support request at


Security Bug fix Policy

As per our new policy critical security bug fixes will be back ported to major software versions for up to 12 months for JIRA and Confluence.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

Binary patches will no longer be released. 

Severity Levels for security issuesAtlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at
End of Life Policy Our end of life policy varies for different products. Please refer to our EOL Policy for details. 
Last modified on Aug 4, 2017

Was this helpful?

Provide feedback about this article
Powered by Confluence and Scroll Viewport.