Certain tasks do not show up in the Task Report Macro
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Some tasks do not appear in a Task Report Macro:
The status (complete or incomplete) of the task and its location may vary from task to task. New Tasks are unaffected.
Diagnosis
One or more of the following things has happened:
- At some point, you may have had problems with duplicate tasks; and used the workaround to remove those duplicate tasks.
- You may have imported content with tasks from an XML Export. For example, a site backup or space export.
Cause
The task entries are not correctly inserted into the database; or the entries may be malformed in some fashion.
Workaround
In Confluence 5.5, tasks were migrated to a new table. This migration process must be re-run again:
Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
- Shut down Confluence
- Perform a full backup of your database
Run the following SQL queries against your database:
delete from "AO_BAF3AA_AOINLINE_TASK"; delete from bandana where bandanakey = 'com.atlassian.confluence.plugins.confluence-inline-tasks:build';
- Restart Confluence
- Verify that all of the tasks are showing up in the report macro as expected
Confluence may take longer to start up if you have a lot of pages in your instance. This is because it's performing the inline task migration - it can take a while on some larger installs - If you're still running into problems, please contact Atlassian Support.
This issue is being tracked as CONF-34751 - Getting issue details... STATUS .