Confluence not displaying the new dashboard after an upgrade to Confluence 5.9
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Confluence 5.9 sports a brand new dashboard that should automatically be installed after an upgrade to version 5.9.x and above, as described in the Confluence 5.9 Release Notes:
However, after an upgrade to Confluence 5.9.x, Confluence is not displaying this new dashboard
Cause
- There are customizations in your instance:
- Go to Confluence Admin > Layouts > and check to see if there are any customizations present.
Your site might be using a page as the site homepage or you may have set your own personal homepage.
- (As a user), Head to Profile > Settings. Check if you have any other page other than Dashboard has been set as your homepage
- If you're an administrator, head to > General Configuration > Further Configuration. Check if you have any other page other than Dashboard has been set as your homepage
Resolution
- Restore all customization in your instance:
- Go to Confluence Admin > Layouts > and backup all the customizations
Make sure that the Global Layout has been set to <default>
Restore the site homepage or personal homepage to Dashboard
- (As a user), Head to Profile > Settings > Edit and choose Dashboard as your homepage. This will set the dashboard as your personal homepage (you can always change it back later).
- If you're an administrator, head to > General Configuration > Further Configuration and set the dashboard as the default homepage for the whole site.