Confluence QuickNavigation or Search Bar is missing
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The navigation bar at the top of your Confluence site, which includes some button/links and the QuickNavigation (Search bar) functionality is missing.
Cause
This can be caused by multiple reasons, amongst the most common ones:
- The Confluence license has expired.
- The 'Confluence Quicknav' bundled plugin is disabled
- A 3rd party plugin is causing this side effect, such as the issue described at Confluence top header menu is not displayed when Comala Document Management is enabled
- In some occasions, a 3rd party plugin can also trigger that some elements are not rendered properly by your browser as described in Side Bar and Top Bar Menu items are missing when using Chrome or Internet Explorer
Solution
Cause 1
Confirm if you have valid Confluence License:
- Browse to General Configuration > License details
- If the license is expired, you will need to renew it.
Cause 2
Confirm that your 'Confluence Quicknav' bundled plugin is enabled:
- Browse to General Configuration > Manage Apps
- Filter by System Apps
- Search by "Confluence Quicknav" and validate that the plugin and all its modules are enabled:
Cause 3
In case this issue is caused by one plugin:
- Enable Safe Mode via General Configuration > Manage Apps > Enter Safe Mode. This will temporarily disable all user-installed plugins
- Open a new Incognito Window in your browser and confirm that the page can now load correctly (minus any plugin functionality)
- Re-enable the plugins one-by-one until the problem can be reproduced again to determine the problematic plugin.
- Exit Safe Mode and then disable only the problematic plugin
- Follow up with the plugin vendor to see if there is a known solution or to investigate further.
Occasionally, customers have reported this issue after a failed try to enter Safe Mode for testing or troubleshooting a different issue.
If that is your case, please follow the steps mentioned in How to reset all Confluence Data Center plugins back to their default state through the database