Disabling External User Does Not Reduce Licensed User Count

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

When external user(s) (LDAP, Crowd, or JIRA) has been successfully disabled, Confluence license count is not reducing even after rebuilding indices from scratch.

Cause

The cause of this issue is because there is a duplicate user name registered in the lower order directory that have the "Can-use Permission".  Here is the relevant bug report in regards to this issue: 

CONF-25412 - Getting issue details... STATUS

(info) For more details on permissions in Confluence, please see Global Permissions Overview

Workaround

The duplicate user(s) registered in the lower order directory need to be disabled or have their "Can-use Permission" removed.

For example if the lower directory is the Confluence internal directory and the higher order directory is JIRA it is necessary to disable or remove "can use" from any duplicate users in the Confluence internal directory. You cannot edit that directory unless you first move it to the top position. If this is done while logged in under the JIRA directory it is possible to get locked out!

  1. Log in first with the Confluence local administrator ID. (To verify that you are logged in under the Confluence directory check whether you have the options to edit the Confluence directory. If you can edit it you are still logged in under JIRA.)
  2. Move the Confluence directory to the top using the blue arrows under Confluence Admin>User Directories. Then you will be able to edit internal Confluence users.
  3. Disable the unwanted users and then move the JIRA directory back to the top. 
  4. Go onto the license page and hit the refresh button. You should see your license count go down.
  5. If you do somehow get locked out of the Confluence administration page please refer to this document.


Last modified on Nov 2, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.