IBM JDK on Z-Series crashes when importing using the Office Connector
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When using "Doc Import" (or "Edit in Word") feature in the office connector, the JVM crashes. Apparently this happens only on IBM's JVM. Because the JVM exits, there is no output in the logs, but you will get a javacore dump in the logs folder.
Cause
This is due to a bug in IBM's JVM.
Resolution
Switch to a supported JDK as listed on this document: Supported Platforms