Manual Index Process Hangs at 99 Percent and Index Queue Fails to Flush
Symptoms
- A manual reindexing of the site hangs at 99% for a long period of time and attachment extractors have already been disabled for diagnostic purposes.
- The recently updated macro is no longer displaying updates.
For Cause 1 the following appears in the atlassian-confluence.log
:
2010-08-11 03:00:00,095 ERROR [DefaultQuartzScheduler_Worker-7] [org.quartz.core.ErrorLogger] schedulerError Job (DEFAULT.IndexQueueFlusher threw an exception.
org.quartz.SchedulerException: Job threw an unhandled exception. [See nested exception: com.atlassian.bonnie.LuceneException: com.atlassian.bonnie.LuceneException: java.io.IOException: There is not enough space on the disk]]
at org.quartz.core.JobRunShell.run(JobRunShell.java:214)
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
\* Nested Exception (Underlying Cause) ---------------
com.atlassian.bonnie.LuceneException: com.atlassian.bonnie.LuceneException: java.io.IOException: There is not enough space on the disk
Cause 1
The local disk that houses the Confluence Home folder is low on space and a new index cannot be built, nor can sequential additions be made by the Index Queue Flusher.
Resolution 1
- Free up space on the drive or migrate the home folder to a new disk space.
- Check to see that the <confluence-home>/backup folder is not overloaded. If it is, consider removing the backup zips and using the recommended Production Backup Strategy.
Cause 2
The tasklist macro creates a new page every time you edit or delete any content from the list.
Depending on the usage, this can render a page with thousand of versions, causing the index to fail and get stuck at some point causing index problems to the whole instance as result.
Resolution 2
Copy the page with the tasklist macro, delete the old page, purge the old page from space trash, and rename the new page. Then try indexing again.