Search and dashboard load slowly - index timestamp is not updated due to file permissions

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

On Linux and Unix based systems, the following symptoms may occur:

  • Searches are very slow, therefore viewing the dashboard is very slow, but otherwise performance is okay.
  • The Index Queue sometimes contains too many entries and entries that are too old.

Cause

The Java method Confluence uses to set the last modified date on the .timestamp file sometimes fails if it is not running as the owner of the file, even when the user does have permission to edit the file.

Resolution

Delete the .timestamp file located in the <Confluence_Home>/index directory. CONF-9228 has additional information.





























Last modified on Jan 16, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.