Searching Using Quick Search Does Not Work

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Symptoms

Normal search works as expected but searches using Quick Search return no results. Rebuilding the index does not resolve the issue.

The following appears in the atlassian-confluence.log:

Caused by: com.google.common.util.concurrent.UncheckedExecutionException: java.lang.IllegalStateException: Required plugin module com.atlassian.plugins.atlassian-nav-links-plugin:rotp-menu was either missing or disabled

Diagnosis

Check if the Atlassian Navigation Links Plugin is disabled in the UPM (Universal Plugin Manager). This plugin supplies the functionality of Quick Search. It is a system plugin which should be enabled by default. If it's disabled, it cannot be enabled through the UI.

If the plugin is disabled in the UPM, check if this plugin is also disabled in the database by running this query:

select BANDANAVALUE from BANDANA where BANDANAKEY = 'plugin.manager.state.Map';

Cause

Atlassian Navigation Links Plugin is disabled.  This can also occur because it is reaching the plugin timeout.

Resolution

To resolve the problem, the plugin needs to be enabled.

Follow workaround #3 from this KB: Plugins are Disabled at Startup and Various Timeout Errors Appear in the Logs After Startup to manually enable the plugin from the database, if the query in the diagnosis section above returned com.atlassian.plugins.atlassian-nav-links-plugin with boolean false.

Otherwise, increase the plugin timeout value to 600 (-Datlassian.plugins.enable.wait=600) and restart Confluence as per the workaround #2 mentioned in the same KB.

Last modified on Nov 1, 2018

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