Seeing #userLink($user) in the People Directory after upgrading Confluence

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

Accounts in the People Directory show with #userLink($user).  The following screen shot demonstrates what is seen:

 

Diagnosis

Search the <confluence install>//confluence/template/includes/macros.vm file for #userLink($user).  If it does not exist in the file, please proceed with the Workaround.

Cause

Due to decorators and customizations, the macros.vm file was corrupted during the upgrade.

Workaround

  1. Backup your database and home directory
  2. Download a Confluence version that matches your current version from the archive
  3. We need to get the macros.vm file from that download. Please find that file in <confluence install>//confluence/template/includes/macros.vm and copy it somewhere that we can easily get to it
  4. Navigate to the same location on your current instance
  5. Take the macros.vm file and move it from this folder
  6. Move the macros.vm file that we recently downloaded, and place it in your folder
  7. Stop and restart the Confluence service
Last modified on Feb 19, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.