Upgrade Fails due to File System Permissions
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Upgrading Confluence fails and an error similar to the following is found in the atlassian-confluence.log file.
SEVERE: Error initializing endpoint
java.net.BindException: Permission denied:80
at org.apache.tomcat.util.net.PoolTcpEndpoint.initEndpoint(PoolTcpEndpoint.java:298)
...
2008-01-14 18:15:32,087 ERROR [main] [com.atlassian.upgrade.AbstractUpgradeManager] doUpgrade Upgrade failed: Couldn't save confluence.cfg.xml to /apps/confluence-home directory.
com.atlassian.config.ConfigurationException: Couldn't save confluence.cfg.xml to /apps/confluence-home directory.
at com.atlassian.config.xml.AbstractDom4jXmlConfigurationPersister.saveDocument(AbstractDom4jXmlConfigurationPersis
...
Caused by: java.io.FileNotFoundException: /apps/confluence-home/confluence.cfg.xml (Permission denied)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
at com.atlassian.core.util.Dom4jUtil.saveDocumentTo(Dom4jUtil.java:27)
Cause
This occurs when the operating system user running Confluence has inadequate write permissions to the Confluence home directory
Resolution
Ensure that the operating system user running Confluence has full read/write permissions to the Confluence home directory