Upgrade to Confluence 5.8.x failed due to Unsupported major.minor version 52.0 (unable to load class com.atlassian.confluence.setup.ConfluenceConfigurationListener)

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Server and Data Center Only - This article only applies to Atlassian products on the server and data center platforms.

Problem

Upgrading to Confluence 5.8.x from 5.7.x or earlier fails. The following appears in the atlassian-confluence.log

java.lang.UnsupportedClassVersionError: 
com/atlassian/confluence/setup/ConfluenceConfigurationListener : 
Unsupported major.minor version 52.0 (unable to load class 
com.atlassian.confluence.setup.ConfluenceConfigurationListener)

Diagnosis

Environment

  • Existing Confluence installation (5.7.x or earlier).
  • Upgrading to Confluence 5.8.x or later.
  • Java version 1.7.x.

Cause

The upgrade is blocked due to a JDK mismatch. Confluence 5.8.x requires Java 1.8.x, and will not function using Java 1.7.x.

See our guide to Supported Platforms for more info.

Resolution

Our guide to Installing Java for Confluence will help you download and install Java 1.8.x for use with Confluence 5.8.x.

tip/resting Created with Sketch.

There's a known issue with Java 1.8.0_25 and 1.8.0_31, and another known issue with Java 1.8.0_45. We don't recommend running Confluence on these versions.

Last modified on Nov 14, 2018

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.