Fisheye and Crucible Security Advisory 2017-11-29

Fisheye and Crucible - Argument injection through filenames in a Mercurial repository - CVE-2017-14591

Note: As of  September 2014 we are no longer issuing binary bug patches, instead we create new maintenance releases for the major versions we are backporting.

Summary

CVE-2017-14591 - Argument injection through Mercurial repository handling.

Advisory Release Date

 10 AM PDT (Pacific Time, -8 hours)

Products Fisheye and Crucible

Affected Versions

  • version < 4.4.3 
  • 4.5.0

Fixed Versions

  • 4.4.3
  • 4.5.1
CVE ID CVE-2017-14591

 

Summary of Vulnerability

This advisory discloses a critical severity security vulnerability which affects Fisheye and Crucible. All versions of Fisheye and Crucible before 4.4.3 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.1 (the fixed version for 4.5.x) are affected by this vulnerability. 

 

Customers who have upgraded their Fisheye and Crucible installations to version 4.4.3 or 4.5.1 are not affected.

Customers who have downloaded and installed Fisheye or Crucible less than version 4.4.3 (the fixed version for 4.4.x)

Customers who have downloaded and installed Fisheye or Crucible >= 4.5.0 less than version 4.5.1 (the fixed version for 4.5.x)

 

Please upgrade your Fisheye and Crucible installations immediately to fix this vulnerability.



Argument injection in Mercurial repository handling (CVE-2017-14591)

Severity

Atlassian rates the severity level of this vulnerability as critical, according to the scale published in our Atlassian severity levels. The scale allows us to rank the severity as critical, high, moderate or low.

This is our assessment and you should evaluate its applicability to your own IT environment.

Description

Fisheye and Crucible did not check that the name of a file in a Mercurial repository contained argument parameters. An attacker who has permission to add a repository or commit to a mercurial repository tracked by Fisheye or Crucible, can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible.

All versions of Fisheye and Crucible before 4.4.3 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.1 (the fixed version for 4.5.x) are affected by this vulnerability. 

This issue can be tracked for Fisheye at: https://jira.atlassian.com/browse/FE-6955 .

This issue can be tracked for Crucible at  https://jira.atlassian.com/browse/CRUC-8121 .

Acknowledgements

Atlassian would like to credit Zhang Tianqi @ Tophant for reporting this issue to us.

Mitigation

Atlassian recommends that you upgrade to the latest version. However, if you are unable to upgrade then you can apply the following mitigation.

This issue can be mitigated by unconfiguring the Mercurial client executable path by following the instructions below 

  1. Go to the admin area of Fisheye or Crucible.
  2. Click Server (under 'Global Settings').
  3. Click Edit Details (under 'Hg Executable').
  4. Set the path to be empty.
  5. Click Update.
  6. Restart your Fisheye server.

For more information on configuring the Mercurial executable path see https://confluence.atlassian.com/display/FISHEYE/Mercurial+Client.

Fix

We have taken the following steps to address this issue:

  1. Released Fisheye version 4.5.1 that contains a fix for this issue.
  2. Released Crucible version 4.5.1 that contains a fix for this issue.
  3. Released Fisheye version 4.4.3 that contains a fix for this issue.
  4. Released Crucible version 4.4.3 that contains a fix for this issue.

What You Need to Do

Atlassian recommends that you upgrade to the latest version. For a full description of the latest version of Fisheye, see the release notes You can download the latest version of Fisheye from the download centre. For a full description of the latest version of Crucible, see the release notes You can download the latest version of Crucible from the download centre.

 

Upgrade Fisheye and Crucible to version 4.5.1 or higher.

If you are running Fisheye or Crucible 4.4.x and cannot upgrade to 4.5.1  then upgrade to version 4.4.3.


Support

If you did not receive an email for this advisory and you wish to receive such emails in the future go to https://my.atlassian.com/email and subscribe to Alerts emails.

If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/.

References

Security Bug fix Policy

As per our new policy critical security bug fixes will be back ported to major software versions for up to 12 months for JIRA and Confluence.  We will release new maintenance releases for the versions covered by the new policy instead of binary patches.

Binary patches will no longer be released. 

Severity Levels for security issues Atlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at FIRST.org.
End of Life Policy  Our end of life policy varies for different products. Please refer to our EOL Policy for details. 
Last modified on Dec 4, 2017

Was this helpful?

Yes
No
Provide feedback about this article

Not finding the help you need?

Ask the community

Powered by Confluence and Scroll Viewport.