Documentation for Confluence 5.4.
Documentation for Confluence OnDemand and earlier versions of Confluence is available too.

Skip to end of metadata
Go to start of metadata

This page provides the download links for the JDBC drivers for all databases currently supported for Confluence. You will need to make the driver available to your application server, as described in the appropriate setup guide.

Note: We bundle some JDBC drivers with Confluence, as shown below. If you are using a direct JDBC connection, you do not need to download or install the drivers that are bundled. If you are connecting via a datasource, or if you are using a database whose driver is not bundled, you will need to download and install the drivers manually.

Database

JDBC driver bundled with Confluence?

JDBC drivers

More information

PostgreSQL

(tick)

8.4-701.jdbc3

The JDBC 3 driver will work under the 1.6 JVM. If you want to use the JDBC 4 driver, you can download it from the PostgreSQL website. However, we recommend that you use the bundled JDBC 3 driver.

Database Setup for PostgreSQL

Microsoft SQL Server

(tick)

jTDS 1.2.2

The above version is the version bundled with Confluence. All our testing is done on that version. We do not know of any issues with later versions., so you are free to use them if you have tested them and find there are no issues in your environment. However, later versions are technically not supported. That means that if you do run into any problems, Atlassian Support may require you to move back to the above fully- tested version for troubleshooting.

Database setup for Microsoft SQL Server

MySQL

(error)

5.1.11

Note: In Confluence 5.1 and later, the MySQL drivers are no longer included in the Confluence distribution. For more information please refer to the Confluence 5.1 Upgrade Notes.

Database setup for MySQL

Oracle

(error)

JDBC driver downloads

  • For Oracle 11.1, use the 10.2.0.4 or 11.1.0.7.0 driver (Java 6 ojdbc6.jar).
  • For Oracle 11.2, use the 11.2.0.1.0 driver (Java 6 ojdbc6.jar).

We recommend using the thin drivers only.

Tip: Search for the JAR file name on the download site.

See the Oracle JDBC driver FAQ.

Database setup for Oracle
  • No labels

14 Comments

  1. Anonymous

    JTDS is now at v1.2.5 -- is there any reason to use 1.2.2 over 1.2.5 for JIRA's sake?

  2. A word of warning to PostgreSQL users.    It is not clearly stated that using PostgreSQL version 9 with Confluence 3.5 (and other versions of Confluence as well) will cause the Plugin Manager to not work.  The solution is easy if you know about it but debilitating it you don't.  Here are the links to the solution: 

    http://confluence.atlassian.com/display/CONFKB/Cannot+install+new+plugins+-+ZipException+-+error+in+opening+zip+file

    http://confluence.atlassian.com/display/CONFKB/Getting+ZipException+Error+when+Installing+a+New+Plugin+Due+to+Postgres+9+Configuration

    http://forums.atlassian.com/message.jspa?messageID=257357112

  3. I'm wondering the same as above, Confluence 3.5.2 comes with jtds 1.2.2 but 1.2.5 is now available.

    Can I simply replace 1.2.2 with 1.2.5 as I am only using Confluence and use no JIRA installation?

    Is there any performance/usablity issues/improvements either way?

  4. Anonymous

    I'm using 1.2.6. Seems to work fine.

  5. I would also like to know the official standpoint on using later versions of JTDS.

    This page implies only 1.2.2 is supported, yet this one directs you to the JTDS Project page, where I suggest most people would automatically download the latest version available, as there is no instruction to the contrary.

    I have been happily using 1.2.6 for a while now, but that has since been superceded by 1.2.7 and now 1.3.0.

    Could Atlassian please comment?

    Thank you.

  6. Hallo Paul, John and all enquiring about the JTDS version (smile)

    I've forwarded your questions to one of our database experts. I'm sure he'll respond soon. If not, I'll chase this up further.

    Cheers, Sarah

      1. Hallo Paul

        I think my database expert must be away for the holidays. Just letting you know I haven't forgotten, and have just now forwarded the question to the support team.

        Cheers, Sarah

        1. Hi all. We currently bundle JTDS 1.2.2 with Confluence, and all our testing is done on that version. Having said that, we don't know of any issues with later versions, so you're free to use them if you have tested them and find there are no issues in your environment, but they are technically not supported. That means that if you do run into any problems, Support may require you to move back to 1.2.2 for troubleshooting.

          Hope this helps!

          1. Hi Denise, thank you for this information.

            I'm surprised Atlassian still test/develop on a version that's now over 5 years old, but if that's how it is then I would at least suggest this page should be suitably amended: As I mentioned above, I imagine most people would automatically download the latest version available (as there is no instruction to the contrary) and would therefore unwittingly end up building a "technically not supported" Confluence instance.

            1. Hallo Paul and Denise

              Thank you for following up on this. I have updated both this page and the SQL Server setup page, to clarify the information about the driver versions.

              Cheers, Sarah

               

  7. Confluence 5.1.2 is compatible with Java 7, but uses jTDS 1.2.2?  Only jTDS 1.3.0 is compatible with Java 7.

    RE: Microsoft SQL Server

  8. Anonymous

    What about if you want to use No SQL db?

  9. Hi,

    it say "For Oracle 11.2, use the 11.2.0.1.0 driver (Java 6 ojdbc6.jar)."  in upgrader instructions (v 3.5.15 -> 4x ->5.x)
    Is that still valid or is it better/ok to use 11.2.0.2.0 (Java 6 ojdbc6.jar) when runnning 11.2.0.2.0?