Inline editing disabled randomly

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Within the View Issue screen, inline editing seems disabled for specific issues in Jira and is available for no fields or some fields.

This behaviour occurs even if 'Inline Editing' is enabled in Jira Settings.

Environment

Jira Data Center

Diagnosis

The Jira issue view shows a typical screen, but without the pencil icon next to any fields you wish to edit in the browse page of an issue: 


Cause

There are a few reasons why Jira could not allow users to edit an inline field when browsing an issue, but they can otherwise edit the same field via the Edit screen.

The leading possible causes for the lack of inline editing are: 

  1. Browser Compatibility: Inline editing may break if the browser is incompatible with Jira. Please check our Supported Platforms page to ensure you use a browser supported by your Jira version.

  2. JavaScript: If you have disabled JavaScript in your browser, it may turn off the inline editing feature.

  3. Screen Fields: Users may encounter issues with inline editing if they don't have the necessary permissions to modify the specific fields. An example is if the field is in the View Screen but not the Edit Screen.

  4. Custom Field Configurations: Inline editing may break if there are custom field configurations that conflict with the inline editing feature, such as calculated fields from a third-party App

  5. Apps: Incompatibility, bugs or conflicts with third-party apps or apps can cause issues with inline editing, such as the Behaviours app, Scriptrunner, or the Table Grid Editor.

Workaround

Inline editing in Jira depends on the function of many features. You will need to investigate the possible causes of each error.

Browsers

Individual users having issues are first suggested to ensure they are using a supported browser such as Chrome, Edge, Firefox or Safari with JavaScript enabled.

Project Configuration

It's impossible to edit fields that aren't also in your Edit Issue screen for the screen scheme associated with the Issue Type Screen Scheme within your Project.

Project Administrators can check if the appropriate fields are on the suitable screens on the Project screens, schemes and Fields page. To change these, you may need a Jira Administrator.

Read more about adding fields to screens as a Jira Administrator on this page.

Custom Field Configuration

Some Custom Fields come from other sources, such as Apps. The Jira Misc Custom Fields (JMCF) by Appfire contains many calculated custom fields that rely on behaviours from other data that don't rely on user input or editing, and this is expected functionality.

Apps

If you are experiencing an issue with a Custom Field due to a third-party App, contact the appropriate vendor via the Atlassian Marketplace and, if necessary, contact Atlassian Support


Last modified on Mar 24, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.