Not able to create new Project in Jira

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

     

Summary

As a Jira administrator, you can create projects for all Jira applications that have been added to your site. You must be logged in as a user with the Jira Administrators or Jira System Administrators as outlined in Managing global permissions

However, it could happen that even Jira Administrators or System Administrators are not able to create new Project in Jira.

Environment

Jira Server / Data Center

Cause

Cause 1:

  • Unable to create Software Project if Issue Type Epic or Story exists and are not Standard
  • When creating a Jira Software Project, you get hit with the error below:

    Hmm... we couldn't create your project due to an unknown error. Try refreshing the page to start again.
  • The issue is outlined in this BUG JSWSERVER-13456 - Getting issue details... STATUS

Cause 2:

  • Jira Software Project type is missing from the Creation Project screen
  • You have Jira Software installed and licensed correctly.
  • You have Jira Software modules enabled on the database as expected at the pluginstate table.
  • However the Jira Software Project type still does not show on the Creation Project screen
  • This is usually affects when Jira is connected to MySQL Database and does not have the REFERENCES permissions to the MySQL user.

Cause 3:

  • Jira Software plugin is disabled on the database
  • Analyzing a HAR file while creating a new Project, a 400 HTTP Bad Request gets thrown along with the following error:

    "projectType": "An invalid project type was specified. Make sure the project type is available in your Jira instance. Please talk to your Jira administrator if you need more help."
  • This behavior is caused by the Jira Software plugin or the modules associated with Jira Software being marked as disabled in your instance's database. You should see the plugin disabled in the Application.xml from a Support Zip as below:

     <key>com.atlassian.jira.jira-software-application</key>
     <name>Jira Software Application</name>
     <version>8.2.3</version>
     <vendor>Atlassian</vendor>
     <status>DISABLED</status>

Solution

Solution for Cause 1: 

  • There is workaround on outlined in the BUG JSWSERVER-13456 - Getting issue details... STATUS
  • Remove (or rename if in use by other custom project) issue types "Story" and "Epic" and create a new project. The issue types will be recreated automatically.

Solution for Cause 2: 

Solution for Cause 3: 

Remove the plugins caches and enable the plugins in the database level:

  1. Stop Jira;
  2. Make a backup of your database;
  3. Make a backup / delete JIRA_HOME/plugins/.bundled-plugins;
  4. Make a backup / delete JIRA_HOME/plugins/.osgi-plugins;
  5. Run the following query below to enable the plugins which are in disabled state;

    DELETE from pluginstate;
  6. Start Jira.


Last modified on Jun 24, 2022

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