Indexing fails with No buffer space available (maximum connections reached?)

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Symptoms

Repository is being stopped because of the following error found inside fisheye-debug.log:

Repository paused due to error com.cenqua.fisheye.rep.RepositoryClientException: org.tigris.subversion.javahl.ClientException: svn: No buffer space available (maximum connections reached?): connect svn: PROPFIND request failed on '/path/to/your/trunk' org.tigris.subversion.javahl.ClientException: svn: No buffer space available (maximum connections reached?): connect svn: PROPFIND request failed on '/path/to/your/trunk' org.tmatesoft.svn.core.SVNException: svn: No buffer space available (maximum connections reached?): connect svn: PROPFIND request failed on '/path/to/your/trunk'

Cause

This usually happens when using Windows 2003 server.

The error occurs when system is attempting to connect from TCP ports greater than 5000. 

Resolution

Go to the windows Registry Editor and increase the number of maximum ephemeral port like doing the following:

  1. Run the Registry Editor in the Administrator privilege.
  2. Open the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters.
  3. Create new DWORD entry, "MaxUserPort", fill with 65534.

 

Last modified on Feb 19, 2016

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