Selecting a changeset results in an error in the UI in Fisheye Crucible - Your request was unable to be processed java.lang.NullPointerException

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Selecting a changeset results in the following message being displayed in the UI:

Your request was unable to be processed

java.lan.NullPointerException - 

 

The following appears in the application log, i.e. atlassian-fisheye-YYYY-MM-DD.log:

2016-07-08 23:14:31,546 ERROR [qtp1710814638-1372 ] fisheye TotalityFilter-logExceptionDetails - Exception "null" (java.lang.NullPointerException) while processing "/changelog/test-repository" (Referer:"null")
java.lang.NullPointerException
at com.cenqua.fisheye.rep.impl.CommonChangeSetDAO.getNextOrPreviousChangeSet(CommonChangeSetDAO.java:1279) [fisheye.jar:?]
at com.cenqua.fisheye.rep.impl.CommonChangeSetDAO.getNextChangeSet(CommonChangeSetDAO.java:1267) [fisheye.jar:?]
at com.cenqua.fisheye.rep.impl.CommonChangeSetDAO.getNextChangeSet(CommonChangeSetDAO.java:79) [fisheye.jar:?]
at com.cenqua.fisheye.cache.BaseRevisionCache.getNextChangeSet(BaseRevisionCache.java:1002) [fisheye.jar:?]
at com.cenqua.fisheye.cache.BaseRevisionCache.getNextChangeSet(BaseRevisionCache.java:103) [fisheye.jar:?]
...

 

Cause

The repository index has become corrupt.

Possible scenario:

  • Upgrades require that all upgrade tasks between the current version and the target version be executed and some major version upgrades require that all repositories be re-indexed. Since this can be a time consuming process these occurrences are extremely limited. The re-index task might fail but the upgrade will succeed leaving a corrupt index.

Workaround

Trigger a manual re-index of the repository:

You might want to enable debug logging (Administration > Server > "Turn Debugging ON") so that if the re-index fails, you'll have captured the necessary data for Support to start investigating the cause. Monitor disk space as the log files can grow considerably depending on the size of the repository.

  1. Navigate to: Administration > Repositories
  2. Select the repository.
  3. Navigate to: Maintenance
  4. Select the "Start" button to the right of "Re-index".

Resolution

TBD

 

Last modified on Jul 31, 2018

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