Error "Field 'xxx' cannot be set. It is not on the appropriate screen, or unknown" on Jira Align Connector

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When there is a problem with the configuration of a custom field on Jira that is integrated with JA, work items that are updated will see the error “Field ‘xxx' cannot be set. It is not on the appropriate screen, or unknown" in the Audit Log (where 'xxx' is the customfield id).

There are 2 main causes for this problem:
A. the field is not present on the screen or
B. the Jira connector doesn’t have permission to create/edit it.

If you are seeing a variation of these errors, that looks like this:

Field '' cannot be set. It is not on the appropriate screen, or unknown


Where the value in between the ' is blank, please refer to the article Error "Field '' cannot be set. It is not on the appropriate screen, or unknown" on Jira Align Connector

Environment

Jira Align Cloud

Diagnosis

Error “Field ‘xxx' cannot be set. It is not on the appropriate screen, or unknown" in the Audit Log.

Cause

There are 2 main causes for this problem:
A. the field is not present on the screen or
B. the Jira connector doesn’t have permission to create/edit it.

Solution

Capture the information on the Jira side about the fields, to do a GET API call can be done using the below syntax.

Create Meta (for the creation screen/when creating items):


https://<jira-url>/rest/api/2/issue/createmeta?expand=projects.issuetypes.fields&projectKeys=<jira-project-key>&issuetypeIds=<issue-type-id>

Edit Meta (for edit screen/ when updating items):

https://<jira-url>/rest/api/2/issue/<issue-key>/editmeta


A. Field is not present

If the field in question is not present on the needed screen, it needs to be added, which can be done with the information present in the Field Best Practices guide.

B. Field is Present, Verify the Jira Connector Permission

In case the field is present, the permission of the Jira connector user needs to be verified. This can be done through the Permission Helper.

  • Jira DC/Server
    • Administration/cog > Project:select your project > Permission > Permission helper
  • Jira Cloud
    • Administration/cog > Project:select your project > Project Settings > Permission > Permission helper

On the Permission Helper pop-up window:

  1. Select the service account used on the integration between JA/Jira

  2. Select one work item that exists on this project

  3. On the Permission, field select the needed permission (like Modify Reporter)

  4. Hit Submit and this will show if the account can create/modify it.

On the page Project Permissions there is a list of the possible ones and what they affect.


Last modified on Nov 28, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.