In Jira Align, the story or feature owner assignment is reverted back to unassigned by the External System

Still need help?

The Atlassian Community is here for you.

Ask the community

Summary

When a story or feature is assigned to an owner in Jira Align, the change is not being synchronized as an Assignee to the related work item in Jira and the owner is cleared out or reverted to its original setting by the external system when the next sync from Jira occurs.

Environment

Jira Align

Diagnosis

The audit log for the work item in Jira Align shows that the owner was changed in Jira Align but then a following entry states that the owner  was reset by External System. 

Cause

This is caused as when the owner is changed in Jira Align, the Jira Connector performs a search into Jira as part of the process to update the assignee of the related work item in Jira, however the Jira Connector is unable to locate the user details in Jira and returns a null response to the search request


There are a few possible causes:

  1. The Jira Align user does not exist in Jira with the corresponding email address (which may not affect all users)

  2. The Jira Connector service account user does not have permission to browse the users in Jira (which typically would affect all users)

  3. Duplicate users exist in Jira with the same email address

  4. The Jira Align users were created originally from Jira but experienced a sync issue during creation that resulted in them receiving a blank External ID  

Solution

  1. Make sure that a user with the email address set in Jira Align exists in Jira.
  2. Make sure that the service account user of the Jira Connector has Browse Users and Groups Global permission as per Jira integration prerequisites (or is a member of a jira-software-users group that has the permissions)
  3. Verify if the user has a duplicate entry in Jira with the same email address. Remove the duplicate user in Jira by re-assigning all the work items to the active user, allowing the duplicate/inactive user to be deleted

  4. If the external ID is blank in the details of the Jira Align (when that users was created by the connector, then use the option to Pull Jira User Data from Jira Align that can be found in Jira Align under Settings/ Administration > Jira Settings > Pull Jira User Data (tab) > “External ID Jira User Field Sync” set to username > Click on “User Pull Data.”



Last modified on Jan 26, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.