Issue links in Jira Test environment point to Production Jira Align after a Jira Data Refresh

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Summary

When a Jira Test instance is refreshed from Production data, the content of the Jira database will be an unmodified copy of the data from the Production instance. This means that the Issue Links created by the Jira Connector for Jira Align will still point to the Jira Align Production instance and not the Jira Align Test instance. This poses a risk that users trying to update a linked issue to the Jira Align Test instance may mistakenly access and update the data held in the Jira Align Prod instance.

Environment

Jira Align

Diagnosis

Clicking the “Jira Align” Web link in a work item in the refreshed Jira Test instance opens the Jira Align Production instance instead of the Jira Align Test instance.

Cause

Jira saves the full URL for Issue Links in its database. These Issue link URLs are static and do not get updated dynamically relative to the environment they reside in. Therefore, when Jira Test is refreshed (overwritten) with Jira Production data, this brings Jira Align Production Issue links with it.

This is mentioned in the following Jira article:

    How to update or change outgoing links from Jira issues and Dashboards | Jira | Atlassian Documentation

   


Solution

A bulk update can be run on the Issue Links to have them point to the correct environment.

for Jira Cloud Customers

Solution 1: Raise a Support Ticket with Jira Cloud Support requesting direct database update of the affected links, stating the data refresh as the reason for the mismatched Issue Links.

Solution 2: Force Jira sync through JQL

As long as a data refresh has also performed on Jira Align Test, make sure the Connector in the Jira Align Test instance has been reconfigured to connect to the correct Jira Test environment before taking the following steps:

  1. In Jira Align navigate to: Administration > Jira Settings > Jira Setup, and confirm “Allow Jira Align to create Jira issue web links” is set to Yes

  2. Navigate to: Administration > Jira Settings > Jira Integration, and run a JQL query to force a sync between Jira Align and Jira.

Things to Note

  • Run time cannot be guaranteed as it is related to the number of work items the customer has.

  • It is recommended to perform this JQL sync outside of business hours

  • Jira Align has a 1000 character length limit for the JQL queries (exceeding this limit can result in an Internal Server error)

  • Avoid "OR" in the JQL query to help with performance

  • In Jira Search Query field, consider using only a date condition (created >= '2014/1/1') to ensure all work items types are selected

  • Set the "Run Board, Sprint and Fix Version sync along with the search query" to "No" as Board Sync is not required


for Jira Server/DC Customers

The same JQL sync approach (Solution 2) used for Cloud customers can also be used for Jira Server/DC customers, however, since such customers have access to their Jira Database, a direct database update using SQL can be done, which may be an easier alternative.


Last modified on Apr 24, 2024

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