Jira Align Connector button missing for some users

Still need help?

The Atlassian Community is here for you.

Ask the community


Summary

When checking the Admin > Jira Setup, the Jira Connector button is not present on the screen.

Environment

Jira Align

Diagnosis

When going to the Admin > Jira Setup, the Jira connector button is not present on the screen, just the name of the current connector, like the below:

Cause

There are 2 possible causes for this problem:

1 - The default configuration for the roles under Admin > Roles > [Role] > Administration > Jira Settings, is marked as Read-Only, like below:

2 - On the Connector settings panel, there are users on the 'Admin' field, and in this case, only they will have access to the button. The field in question is shown below:

Solution

For scenario 1 above, the fix is to remove the Read-Only, under the Role > Administration > Jira Settings, save the role, and ask the user to log out/log in

For scenario 2, the person can be added as an Admin OR remove all the Admin (if left blank, everyone with the right permission can see the button)


Last modified on Mar 3, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.