Repeated Remote Issue Link Updates in Jira History from Jira Align

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Summary

In a Jira Project synced with Jira Align, users observe that the Jira Align connector is repeatedly updating the History log of synced work items. The History shows consecutive updates of the Remote Issue Link of Jira Align being removed and replaced.

This behaviour is continuous, and the History log will keep growing until the connector configuration issue is resolved on Jira Align.

Environment

Jira Align

Diagnosis

The History on the Jira work item, for example, Story or Task, will have multiple updates from the Jira Align service account utilised by the connector.

Cause

A duplicated connector configuration of the Jira issue type causes this.

So a Jira issue type, for example, Task, has been configured on the Jira Connector in Jira Align and mapped to a Jira Align Issue Type and Custom Issue Type simultaneously.

A single Jira Issue Type ID will be configured in both;

  • Settings > Jira Settings > Jira Setup (tab) > Issue Types (section)
  • Settings > Jira Settings > Custom Issue Types (tab)


When you have this duplicated configuration, the Jira connector sync process will sync the item from Jira to Jira Align as the Issue Type. It will also attempt to sync it again as a Custom Issue Type, but the existing item must be deleted as a duplicate item of a different type can't be created. This deletion and creation will continue on every sync, including removing and updating the Jira Align Link on Jira.

Solution

Review the Jira Issue Type ID configurations and ensure that no issue type is configured more than once across both config locations;

  • Settings > Jira Settings > Jira Setup (tab) > Issue Types (section)
  • Settings > Jira Settings > Custom Issue Types (tab)


Last modified on May 28, 2024

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