Canned Response button missing from the comment section
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When trying to comment on a Service Desk issue, the canned response button is missing from the top menu of the comment field:
Expected behavior
The canned response button should be available in the top menu:
Cause
This issue might happen due to either of the reasons below:
- You are running Service Desk on a version lower than 3.7.0
- The Service Desk Canned Response plugin is disabled in the Add-on management page
- The Canned Response functionality is disabled in the Dark Feature page
- The 3rd party add-on ScriptRunner for JIRA is causing the issue
- The rich text editor is currently disabled
Resolution
For Cause 1:
- Upgrade Service Des to version 3.7.0 or later, since the canned response feature was introduced in this version, per the 3.7.x release notes.
For Cause 2:
Check if any of the Service Desk Canned Response Plugin modules is disabled in the Manage add-ons page by following the steps below:
- Choose > Add-ons > Manage add-ons
- Select "All add-ons" in the drop down menu located next to the search box
- Look for Service Desk Canned Response Plugin and expand it
- Click on the list of modules and check if any module is disabled (see example below):
- If any of the module is disabled, click on the Enable button next to any of the disabled modules
For Cause 3:
Check if the Canned Response feature is disabled in the Dark Feature page by following the steps below:
- Go to the URL box in your browser and enter the following address: <hostname>/secure/admin/SiteDarkFeatures!Default.jspa (e.g. http://jira.examplecompany.com/secure/admin/SiteDarkFeatures!Default.jspa)
- Within Site Wide Dark Features check if sd.canned.responses.enabled is listed, as shown in the screenshot below:
- If the feature is missing, add it by entering sd.canned.responses.enabled in the Enable dark feature box and clicking on the Add button, as shown below:
For Cause 4:
There has been a few reports of the ScriptRunner add-on preventing the Canned Response button from being displayed, especially if a version lower than 5.3.9 is installed. If you have ScriptRunner installed, try to follow either of the steps below and check if the canned response button comes back:
- Disable the ScriptRunner add-on from the page > Add-ons > Manage add-ons
- Or try to upgrade ScriptRunner to 5.3.9 or a higher version
For Cause 5:
Enable the rich text editor, as explained in this KB article