Display problems when browsing Jira server with Internet Explorer in Compatibility or Enterprise modes

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Symptoms

You are using Internet Explorer (8 and onwards) and are experiencing problems with user interface items (for example: Menu not expanding, or links overlapping).  

You might also see a banner specifying that you have an unsupported browser (IE 11 with Enterprise Mode).

It may also be noticed that the problem disappears after switching to other browsers.

Cause

  1. JIRA cannot work with Internet Explorer in Compatibility mode. Compatibility mode on IE was designed to balance new features and functionality with site compatibility for the existing Web. Internet Explorer defaults to Compatibility mode especially for intranet sites. This setting does not work well with JIRA and is also not part of the supported platforms.
  2. Document Mode in Internet Explorer has been seen to default to IE7 in some cases and can cause issues. If this happens, the correct rendering of pages can be affected.
  3. JIRA cannot work with Internet Explorer 11 in Enterprise Mode either.   The difference between Enterprise Mode and Compatibility mode is described on this article

Resolution

There are a few options to try in this situation. All of the below options would work to switch to standard mode on Internet Explorer.

  1. Disable compatibility mode in Internet Explorer displaying intranet sites with compatibility mode.
  2. (Server customers only) Disable compatibility mode for JIRA by following the suggestion mentioned in this issue. (Although this is a customization and not officially supported by Atlassian Support).
  3. (Server customers only) You could also install Chrome Frame for Internet Explorer. After this, you would need to add this code to the Announcement Banner and that would tell Jira to use Chrome to display the pages.
    1. (info) This solution has not been product tested and is not officially supported by Atlassian Support
  4. Fix Document Mode settings in Internet Explorer - To change this, access Developer Tools in Internet Explorer and change the 'Document Mode' to version >= IE8 
    1. (warning) Users may also need to uncheck the "IE8 Standards" option
  5. If you are on Internet Explorer 11 and you have already disabled Compatibility Mode or you haven't set up Compatibility Mode then you will also need to disable Enterprise Mode as detailed on this article.

Last modified on Sep 25, 2019

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