Error arises when using Affects versions in JQL.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
The following error arises when using Affects versions in JQL.
"The field does not exist, or you do not have permission to view it."
Environment
Cloud
Cause
In JQL, the term "affected versions" is denoted as affectedVersion. This inconsistency is leading to the error, as JQL does not identify the "affected versions" field.
Solution
In JQL, it is recommended to use affectedVersion instead of "Affects versions" because JQL recognizes "Affects versions" as affectedVersion, and according to JQL, there is no field named "Affects versions".