How to avoid duplicated priorities and fix migrated values
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Duplicate priorities are present as follows especially after a migration:
"Lowest", "Low", "Medium", "High" and "Highest" and "Lowest(migrated)", "Low(migrated)", "Medium(migrated)", "High(migrated)" and "Highest(migrated)".
Why are duplicates seen and how to fix them?
Cause
Two priorities with the same name and the same color associated with them are considered equal and will be merged.
If two priorities have the same name but different colors, one of them will be created with a (migrated) tag.
Solution
It is best to modify the priority before migration to ensure that the priorities have the same name and color.
However, if this is not done and there are such duplicate priorities present the following can be done to fix this:
The values of the built-in Priority field are managed in a global list which can be found at Admin Settings (the gear icon) > Issues > Priorities. This screen is used to edit or delete priorities.
In the case of deleting a priority, the issues that contain the value to be deleted will need to be updated to another valid value.
When deleting a priority, a user would be asked to choose where to move the issues that are currently listed as, for example, "Highest (migrated)". Here, the user would be able to select "Highest" from the drop-down and all of those tickets would move over. This can be repeated until there are no more duplicate priority statuses.
Please be aware that this could affect the existing project's information with regards to:
- Automation rules
- Reports and Dashboards (using JQL queries)
- Filter queries
The automation rules for example might be using the priority ID and not the priority name, so those may need to be edited to work again.