Incorrect date/time format in exported issues
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
This article applies to jira issues exported from search results as mentioned here: Export search results. Sometimes, it can happen that the data in the date/time fields such as Created and Updated fields of the exported file are corrupted or incorrect. Attaching a sample screenshot below:
Environment
Jira Cloud
Cause
The date and time format of the exported issues is governed by the setting configured under Date / time formats of the Jira cloud instance. If it is not set correctly, the exported date data will be corrupted.
For example, a valid format would be yyyy-MM-dd hh:mm:ss but an invalid format would be yyyy-MMM-dd hh:mm:ss.
Solution
You should be a Jira administrator to make this change.
Choose > System
Under USER INTERFACE, select Look and feel
In the Date/time formats section, correct the Complete Date/Time Format with an appropriate value from the guide on how to set date/time: SimpleDateFormat
To know more about this configuration, please check Configure the look and feel of Jira applications