Invalid date when trying to Log Work on Issue in JIRA
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to Log Work on an Issue in JIRA, the Date Started field shows a invalid date or returns an error when a valid date is entered, like this:
Diagnosis
Check the Date/Time Formats in JIRA Configuration:
- Administration > System > User Interface > Look & Feel > Date/Time Formats
Check the Advanced Settings for Date Picker and Date Format:
- Administration > System > General Configuration > Advanced Setting
Cause
Date and Time picker formats are not are not matching in JIRA's Advanced Settings.
Resolution
- Go to Administration > General Configuration > Advanced Setting
- Verify the key jira.date.picker.java.format corresponds with the key jira.date.picker.javascript.format
- Verify the key jira.date.time.picker.java.format corresponds with the key jira.date.time.picker.javascript.format
See here for more on Configuring date picker formats