Issues can’t be manually ranked error is observed when ranking issues in the Backlog.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
The below error related to the Board filter is received when trying to rank issues in the Backlog.
Issues can’t be manually ranked
The board’s filter query isn’t sorted by rank. To
rank issues manually on your board and backlog,
sort issues by ascending rank.
- Environment
Jira Cloud- Software projects.
Diagnosis
The Enable ranking document as followed and ORDER BY Rank
was included in the board filter.
However, it was observed that the ORDER BY Rank
was included after a different ordering property.
This resulted in Ranking not being enabled on the Board.
Cause
To be able to Rank an issue on your board, Ranking needs to be the primary sot parameter. ORDER BY Rank
cannot be used as a secondary sort parameter in the board filter.
Solution
The board filter needs to be updated to ensure that Ranking is the primary Sort paramater as seen in the below example.
Example:
Project= "<Project name>" ORDER BY Rank ASC, priority DESC
The above might not be helpful in few situations as making ranking primary sort parameter would change the ordering of issues on the board.
If you are looking to order by your primary parameter(example priority) and still want to Rank issues on the board, follow the below workaround.
1. Create a New Filter: Create a new filter using only the primary sort parameter.
Save this filter with a distinctive name, and ensure it's shared with all relevant users who need access to this view.
2. Modify the Existing Filter: Edit your existing Board filter to reference the newly created filter(in Step 1).
After this, add an ORDER BY Rank
sorting. This sequence ensures that while Priority dictates the initial ordering, the Ranking functionality remains intact for further sorting within those priority levels.
3. Verify on the Board: Save your changes and navigate to your board to confirm Ranking is enabled.