Issues created by 'Anonymous' user in Jira

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

There are multiple issues with the reporter set as "Anonymous", however, Jira configuration does not allow anonymous access.


Diagnosis

Case 1: 
Review User Management if there is a user 'Anonymous' created on LDAP or on the Jira Internal Directory. 


Case 2:
The auto-filling reporter field was disabled to prevent Jira from pre-setting the reporter with the current use.

Review the article HowTo disable auto filling reporter field when creating issues and check if the Velocity template reporter-edit-frother.vm located under $JIRA_INSTALLATION_DIRECOTRY/atlassian-jira/WEB-INF/classes/templates/jira/issue/field is commented out. If you edit an issue to change some field, it will reset the Reporter field to Anonymous if you don't fill the Reporter field again.

...
#** Comment out the lines which pre fill the reporter
        #if ($reporterDisplayName)

            #set ($username = $textutils.htmlEncode($reporter))
            #set ($displayName = $textutils.htmlEncode($reporterDisplayName))

            <option selected="selected"
                    class="current-user"
                    data-field-text="$displayName"
                    data-icon="$reporterAvatarUrl"
                    value="$username">$displayName</option>

        #end
*#
...



Case 3:
(Working as expected)
The reporter field is not a required field by default and users can leave it empty if they choose to, which leads to the appearance of the "?" Anonymous.


Solution

Case 1:
Deactivate the account 'Anonymous" following the instructions under the "Deactivating users" session in Create, edit, or remove a user documentation. 

Case 2 and case 3:
Change the field configuration to make it mandatory, following the documentation Making a field required or optional.


Last modified on Dec 26, 2023

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