JIRA Invalid Date or Time Displayed Within 'Work Log' in Activity Panel of Issue

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Symptoms

In JIRA when reviewing the Activity panel for an issue with logged time an invalid date is displayed:

Cause

JIRA Cloud 'Look and Feel' allows customization of 'Date/Time Formats'.  There are additional configuration items available for JIRA installed: Invalid date when trying to Log Work in Jira Data Center  

Resolution

  • Cog icon > System - User Interface > Look and Feel
  • Bottom of the page has 'Date/Time Formats'
  • Select 'Revert' to restore the previous settings or
  • Edit the settings to match the Simple Date Link

    (info) info is good

Last modified on Jan 10, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.