Negative number field shows as zero in issue history

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Workaround that negative values in a custom number field show as zero in the issue history.

Steps:

  • Add a custom number field to an issue in a Jira Software or Service Desk project.
  • Put a positive number and a negative number here.
  • Check the issue history. The negative number will be always be shown as 0.

Environment

Jira Cloud

Diagnosis

  • The custom field itself has the right negative value added. Only the history entry shows the value as "0" instead of the negative value.

Cause

This is caused due to the bug: JRACLOUD-75500 - A negative value in a custom number field will be shown as zero in the issue history.

Solution

While we don't have a workaround to correct the Jira Cloud history entry from the UI, here is a suggestion to get the audit the logging using Automation for Jira:

  • Trigger: When value changes for the custom field "Number"
  • Condition: If number field value is less than 0
  • Action: Add a comment on the issue:
The value of the "number" field has been changed from {{changelog.number.fromString}} to {{changelog.number.toString}}


Screen recording of the rule:

Screen Recording 2024-04-23 at 1.33.38 PM_2024-04-23T08_05_17.505Z.mov


Automation rule JSON file:

automation-rule-19028267-202404230856_2024-04-23T08_56_31.950Z.json



Last modified on Jan 31, 2025

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