New issues are being created with the resolved date set
Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The Resolved date is automatically set for newly created issues.
Cause
The resolution field was added to the "Issue Create" screen on this issue type.
Clarification
The Resolved field is a system date field that uses the last update date on the Resolution field in order to change the value for the issue date on the resolution date.
This means that when the Resolution field is added to the issue creation screen there is actually a value change on the resolution field as a value input is required by default, which in turn triggers the update of the Resolved Date field.
Solution
Remove the Resolution field from the "create issue" screen. This will prevent the resolution field from being set and therefore the same for the Resolved Date field.