Transition screen returns "Internal server error" when transitioning issue
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
On some rare occasions, when using a "Field will be cleared" workflow post function for the Assignee field, and while transitioning an issue that uses an issue screen, the error message "Internal server error" may be displayed when confirming the entered screen data, for example:
Cause
This happens due to on the database the assignee field is mistakenly pointing to a user who is no longer part of your site. While in the UI there is no such configuration inside the post function but the database still shows the configuration. This means at one point the configuration did exist but wasn't deleted properly from the database when removed from UI.
Solution
In order to resolve this issue, access the affected issue type workflow:
Select ⚙ > Issues.
Click Workflows.
Select the workflow transition that's facing the "Internal server error" message and click Edit.
In the Workflow Editor, select the transition.
Click Post functions in the properties panel.
Afterwards, proceed with the following steps:
- Delete the Assignee of the issue that will be cleared post function.
- Add the Assign the issue to the lead developer post function.
- Publish the workflow.
- Edit the workflow again.
- Delete the Assign the issue to the lead developer post function.
- Add The value of the field Assignee will be cleared post function.
- Publish the workflow.
This will re-sync the post-function data allowing to successful transition of the issue to the target status.
Relevant links
- Configure advanced issue workflows
- Manage issue screens
- JRACLOUD-75732 - Meaningful error message instead of generic 500 Internal server error for workflows