Troubleshooting required-field errors

Still need help?

The Atlassian Community is here for you.

Ask the community


Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.


Summary

Sometimes an issue can only be created if there is a value in a certain field. This article will help you identify if that is the reason you are blocked from creating an issue, and show you how to change this behaviour.

Cause

In Jira Cloud company-managed projects there are two ways to make a field required:

Depending on which requirement has been setup on your project, you will see different error messages. Furthermore, if you have a required field but you have not put it on your create screen, users may be blocked from creating issues.

Examples where a field is required by a field configuration

When a field has been marked Required in your field configuration AND that field appears on the create screen, you will see the field highlighted with an asterisk and the error message "<field name> is required":

When a field has been marked Required in your field configuration but that field has not been put on the create screen, you will see a red box with the text "<field name>: <field name> is required". Users will not be able to create issues until (a) you add the field to the create screen and the field is given a value on the create screen (b) you remove the field requirement from the field configuration OR (c) you give a default value to the field (if possible for the field type):

Examples where a field is required by a workflow validator

When a field is required by a workflow validator that has no custom error message configured, you will see the following red box error with the text "Field <field name> is required."

Note, if you do use a custom error message in your workflow validator, you should make it as descriptive as possible - make it clear what is required of the user e.g "Required by workflow validator: <field name> must have a value":

Example when a field is required on a subtask

The error messages look a bit different when creating subtasks. If you try to create a subtask and the required field is on the create screen,  a larger modal will pop-up prompting you to enter the required value. If the required field is not on the create screen you will see the following pop-up error with the text "We couldn't create the subtask. <Field name>: <Field name> is required"

Solutions

Update the field configuration

  1. Note that all changes made to a field configuration will affect all projects that use that field configuration. To remove a field requirement from a field configuration go to https://<your site name>.atlassian.net/plugins/servlet/project-config/<project key>/fields
  2. Click on the Pencil symbol next to the field configuration
  3. Search for the field. You will see it has a "Required" badge. This will disappear once you click the "Optional" link in the Actions column:



Update the workflow

  1. Note that all changes made to a workflow will affect all projects that use that workflow. Go to https://<your site name>.atlassian.net/plugins/servlet/project-config/<project key>/workflows
  2. Click on the Pencil symbol next to the workflow
  3. Click the Diagram button and then on the Create transition line (it's the only line that comes out of the grey circle). Then click Validators:
  4. In the row with the validator, hover your mouse and click the cross symbol to delete the validator:
  5. Click Publish draft



Last modified on Nov 21, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.