Unable to see tabs on screens for some users
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When viewing or editing a screen, some users might not be able to view the tabs for that screen but other users with similar permissions/groups/roles can still view the tabs.
For example, some users are able to view the following tabs on the screen:
But for certain users, they will not be able to view the tabs:
Cause
There are custom scripts designed to hide the fields/tabs on the field configuration. Note that custom scripts fall under customization in the Atlassian Support Offerings therefore Atlassian Support would not be able to assist in making the script work as you intended it to be.
Diagnose
Run the following SQL query in your database to validate if you have any fields with custom scripts to hide the field:
select id, fieldidentifier, description from fieldlayoutitem where description like '%.hide%';
- Go to the Field Configuration Scheme > Edit > Look for the missing fields that were supposed to appear on the tab and check for custom scripts
- Below is an example on how the custom script might look like:
<script type="text/javascript">
(function($) {
AJS.toInit(function(){
// init on load
AJS.$("#qf-field-picker-trigger").hide();
})
JIRA.bind(JIRA.Events.NEW_CONTENT_ADDED, function (e, context) {
// init on refresh
AJS.$("#qf-field-picker-trigger").hide();
});
})(AJS.$);
</script>
Resolution
Remove the custom scripts to allow the affected users to be able to view the tabs again.