Unable To See User Avatars In JIRA - Only See Default Image
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Symptoms
A single or multiple users do not see actual user avatars in JIRA, but do see the default image. These are not broken links, but are defaulting to stock images.
Cause
This is generally related to the Browse Users Global Permission in JIRA - if you do not have this permission you will not see that user's details (including avatar picture).
Resolution
Check what groups are assigned to the Browse Users Global Permission:
- Type g+g in JIRA and you will get the search menu, where you can begin typing Global Permissions
- Clicking on Global Permissions will bring you to the permissions page which will list which groups have the Browse Users permission
- This will usually be jira-users, users, and/or jira-access
- Take note of this and make sure the user having the issue is added to this group.