Unable to set the the issue type hierarchy of Epic issue type if created manually after a deletion
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When the default issue type Epic is deleted, it breaks the Issue type hierarchy set under Setting > Issues > Issue type hierarchy. Even if you create the issue type manually, you can no longer select it under Jira Issue Types to add a hierarchy level.
Environment
Jira Cloud
Diagnosis
Issue Type Epic bear hierarchy level 1 while all the other standard issue types bear the hierarchy level 0. Subtasks bear the lowest hierarchy i.e. -1. This is explained in detail under the 'What are issue type hierarchy levels?' section of the following page: What are issue types?
The issue type hierarchy settings allow you to manage the default hierarchy levels for issue types in Jira. Jira Premium and Enterprise customers can also create additional levels in their issue type hierarchy. Learn more about managing the issue type hierarchy.
If you use Advanced Roadmaps, additional hierarchy levels can allow you to track your organization’s larger initiatives in your plans and unify cross-project work. Learn more about configuring the issue type hierarchy in Advanced Roadmaps.
Cause
When you delete the default issue type Epic where the hierarch level is already present, the link between the Level Name and the Issue Type is broken. When you try creating the issue type manually, there is no option to select the hierarchy level of the issue type as 1:
Solution
You need to be an Jira administrator to perform the steps:
- Delete the manually created Epic issue type
- Create a new Software project. Refer to the instructions here. This will automatically create a new Issue Type Epic with hierarchy level 1
- Navigate to Setting > Issues > Issue type hierarchy to verify if the Level Name is restored again