Unable to set the the issue type hierarchy of Epic issue type if created manually after a deletion


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When the default issue type Epic is deleted, it breaks the Issue type hierarchy set under Setting > Issues > Issue type hierarchy. Even if you create the issue type manually, you can no longer select it under Jira Issue Types to add a hierarchy level.

Environment

Jira Cloud

Diagnosis

Issue Type Epic bear hierarchy level 1 while all the other standard issue types bear the hierarchy level 0. Subtasks bear the lowest hierarchy i.e. -1. This is explained in detail under the 'What are issue type hierarchy levels?' section of the following page: What are issue types?

Issue type hierarchy levels

By default, Jira supports three levels of hierarchy:

  • Epic issues, which represent high-level initiatives or bigger pieces of work in Jira. For software teams, an epic may represent a new feature they're developing. For IT service teams, epics may represent a major service change or upgrade. For business teams, epics may represent major deliverables or phases of a project.

  • Standard issues represent regular business tasks. In Jira, standard issues are where daily work is discussed and carried out by team members. For software teams, standard issues (like bugs or stories) estimate and track the effort required to build an interaction or other end goal in your team's software. For service teams, standard issues represent different requests made by your team's customers, like requesting service or support, or reporting problems or incidents with your infrastructure. For business teams, standard issues represent and track your team member's daily tasks.

  • Subtask issues, which can help your team break a standard issue into smaller chunks. This can be helpful if your team has a task that requires multiple people working on it, or if your team underestimates the scope or complexity of their work. Subtasks can be described and estimated separately to their related standard issue and can help your team better understand and estimate similar work in the future.

The issue type hierarchy settings allow you to manage the default hierarchy levels for issue types in Jira. Jira Premium and Enterprise customers can also create additional levels in their issue type hierarchy. Learn more about managing the issue type hierarchy.

If you use Advanced Roadmaps, additional hierarchy levels can allow you to track your organization’s larger initiatives in your plans and unify cross-project work. Learn more about configuring the issue type hierarchy in Advanced Roadmaps.

Cause

When you delete the default issue type Epic where the hierarch level is already present, the link between the Level Name and the Issue Type is broken. When you try creating the issue type manually, there is no option to select the hierarchy level of the issue type as 1:

Solution

You need to be an Jira administrator to perform the steps:

  1. Delete the manually created Epic issue type
  2. Create a new Software project. Refer to the instructions here. This will automatically create a new Issue Type Epic with hierarchy level 1
  3. Navigate to Setting > Issues > Issue type hierarchy to verify if the Level Name is restored again
Last modified on Jul 25, 2023

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