Issues are not showing in Kanban board

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

As per this article, the description of Hide completed issues older than function mentions that the function applies to issues in the 'Done' column, which should be the last column. However, when configuring a Kanban board and setting the option Hide completed issues older than in Board > Configure > General and filter, it also hides other issues in other columns besides the one in the 'Done' column. 

Cause

Cause #1

The column is configured to have a 'Done' status category.

Cause #2

The issues filtered in the column is in a status with no status category. For example, when checking the issue that is filtered, you notice that the issue below has a grayed out status.

When heading to Admin > Issues > Statuses, we can see that the status Waiting for Customer does not have a status category.

Solution

Resolution #1

Change the status category of the column.

Resolution #2

Add the status category for the affected statuses.

  • Go to Statuses page by choosing Cog Icon  > Issues > Find  Statuses  under Issue Attributes category at the left.
  • Search for the affected status and click on Edit.
  • Choose a category that fits the status and click Update.
  • Try to replicate the issue again.


Last modified on Sep 26, 2022

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