Some issue types are missing from an Advanced Roadmaps Plan
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When using Jira with Advanced Roadmaps (previously known as Portfolio), some issue types are not visible.
Create a new issue in the plan using the affected issue type, when you Review changes and Save selected changes In Jira you encounter the following error:
Error
This issue is missing some details that are specified in the issue sources of your plan. To make this issue visible, add these missing details to the issue.
Environment
All Jira and Advanced Roadmap versions
Cause
This may occur when the issue type is using a Field configuration where the "Fix Version/s" system field was hidden from the Field configuration. "Fix Version/s" is a required field for Advanced Roadmaps. Advanced Roadmaps relies on Fix Versions from Jira to define releases. See Managing Releases for additional information.
Solution
- Edit the Field Configuration used by the Issue Type;
- Select Show to add the "Fix Version/s" field;
- Reindex the project
- Plan view will show the missed issues from that issue type after refreshing the page.
If the issue persists, additional troubleshooting steps are available at Troubleshooting missing issues.
There are other known potential causes for issue not being displayed on a plan. You can review them here:
Some issues are missing from plans in Advanced Roadmaps for Jira