Disabled the health task related to checking the database (Task 51111 failed)
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Instructions not meant for production environments
This procedure described here is strongly not recommended for production environments. You might want to disable this compatibility check exclusively for test purposes.
Summary
During the Bamboo upgrade, when using a non-supported Database, the following error may occur:
Error at the UI should look like this:
Bamboo bootstrap failed: Your Bamboo instance could not start because the health check failed. Contact Atlassian Support at https://support.atlassian.com
The error at the log should look like this:
2021-11-12 11:03:02,416 INFO [localhost-startStop-1] [DatabaseIsSupported] Testing compatibility of [Microsoft SQL Server] 12.0.0 (12.00.2255) using JDBC driver [Microsoft JDBC Driver 8.2 for SQL Server] 8.2.0 (8.2.2.0) with this version of Bamboo.
2021-11-12 11:03:02,416 ERROR [localhost-startStop-1] [DatabaseIsSupported] Detected MSSQL version [Microsoft SQL Server] 12.0.0 (12.00.2255), minimal supported version is 13.0.0
2021-11-12 11:03:02,416 ERROR [localhost-startStop-1] [DatabaseIsSupported] Bamboo doesn't support Microsoft SQL Server version 12.00.2255. Please check https://confluence.atlassian.com/display/BAMBOO/Supported+Platforms for more information.
2021-11-12 11:03:02,416 ERROR [localhost-startStop-1] [BootstrapUpgradeManagerImpl] Task 51111 failed
com.atlassian.upgrade.UpgradeException: Bamboo doesn't support Microsoft SQL Server version 12.00.2255. Please check https://confluence.atlassian.com/display/BAMBOO/Supported+Platforms for more information.
at com.atlassian.bamboo.upgrade.tasks.validation.DatabaseIsSupported.doUpgrade(DatabaseIsSupported.java:92)
Diagnosis
When using a non-supported Database, It's expected that Bamboo will fail and won't let you complete your upgrade/migration.
Check the Supported Platforms page for the Bamboo version you're upgrading to before installing the new version in your production environment.
Solution
To bypass it in your test environment follow this procedure:
- Go to <Bamboo installation>/atlassian-bamboo/WEB-INF/classes and open the upgrades.xml file
- Comment the following parameter: <upgrade build="51111" build-min="0" build-max="999999" class="com.atlassian.bamboo.upgrade.tasks.validation.DatabaseIsSupported"/>
- Restart the Bamboo upgrade
- It should now bypass task 51111.