Issues when the "Bitbucket Server - Comment Likes" system plugin is disabled
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
This page describes the issues that are observed when the Bitbucket Server - Comment Likes system plugin is disabled.
Bitbucket versions <= 6.x
For Bitbucket versions 6.x and earlier, the "Like" link in pull request comments will not be shown if the system plugin is disabled.
Here are screenshots illustrating the issue:
Plugin is enabled The "Like" link is visible | |
Plugin is disabled The "Like" link is missing |
Bitbucket versions >= 7.0 and < 7.7
In Bitbucket 7.0, pull requests got a makeover and the "Like" link was replaced with a "thumbs up" emoji.
If the system plugin is not enabled, clicking the thumbs up emoji will return a "Comment not found - The requested comment does not exist. It may have been deleted." message, as shown below:
Bitbucket versions >= 7.7
Bitbucket 7.7 introduced comment reactions, which replaced the "thumbs up" emoji.
If the system plugin is not enabled, selecting an emoji reaction will return the error message, "An error occurred - Something went wrong while trying to serve your request. Try reloading the page."
Cause
The system plugin may have been disabled by mistake or failed to get enabled during a restart.
Solution
To address the issues, enable the "Bitbucket Server - Comments Likes" system plugin (plugin key: com.atlassian.bitbucket.server.bitbucket-comment-likes
)
Procedures
- Log on as a system admin user
- Go to Administration > Manage apps
- Select "System" from the dropdown list in the "Manage apps" list to show the system plugins
- Look for "Bitbucket Server - Comment Likes" and click the "Enable" button